MIT License

项目介绍

ireader/media-server 是一个托管在 GitHub 上的开源项目,主要使用 C 编写,采用 MIT License 许可证,目前获得 3.5k 个 Star、1.2k 次 Fork。

仓库全名
ireader/media-server
开源许可证
MIT License
Star 数
3.5k
Fork 数
1.2k
未关闭 Issue
108

README 摘要

Build Dependence: https://github.com/ireader/sdk libflv 1. FLV video codec: H.264/H.265/H.266/AV1/VP8/VP9/VP10 2. FLV audio codec: AAC/MP3/G.711/Opus 3. FLV file read/write 4. H.264/H.265/H.266/AV1 bitstream filter: annex-b mp4 stream 5. AAC bitstream filter: ADTS ASC librtmp 1. rtmp-client: RTMP publish/play 2. rtmp-server: RTMP Server live/vod streaming libmpeg 1. ITU-T H.222.0 PS/TS read/write 2. ps/ts codec…

完整内容见 GitHub 原始 README 或本页 。

常见问题

media-server 用什么语言开发?

主要使用 C 编写,采用 MIT License 许可证,目前有 3.5k 个 Star。

media-server 可以免费商用吗?

仓库采用 MIT License 许可证,可免费使用与修改,商业使用请遵守许可证条款(例如保留版权声明与许可声明)。

如何获取 media-server 的源码?

可以直接克隆仓库:git clone https://github.com/ireader/media-server.git,默认分支为 master;安装与运行步骤见仓库 README。

media-server 最近还在维护吗?

仓库最近一次更新为 4 周前,当前有 108 个未关闭 Issue;Star 数为 3.5k,可作为社区活跃度的参考。

简要分析

热度分
6047
价值分
2480
活跃状态
活跃

语言占比

C
C++
Makefile

README

libflv

  1. FLV video codec: H.264/H.265/H.266/AV1/VP8/VP9/VP10
  2. FLV audio codec: AAC/MP3/G.711/Opus
  3. FLV file read/write
  4. H.264/H.265/H.266/AV1 bitstream filter: annex-b <-> mp4 stream
  5. AAC bitstream filter: ADTS <-> ASC

librtmp

  1. rtmp-client: RTMP publish/play
  2. rtmp-server: RTMP Server live/vod streaming

libmpeg

  1. ITU-T H.222.0 PS/TS read/write
  2. ps/ts codec: H.264/H.265/H.266/AAC/MP3/G.711/Opus

librtp

  1. RFC3550 RTP/RTCP
  2. RTP with H.264/H.265/H.266/MPEG-2/MPEG-4/VP8/VP9/AV1
  3. RTP with G.711/G.726/G.729/MP3/AAC/Opus
  4. RTP with MPEG-2 PS/TS
  5. RTP Header Extension
  6. RTCP PSFB/RTPFB/XR

librtsp

  1. RFC2326 RTSP
  2. RFC4566 SDP
  3. SDP fmtp: H.264/H.265/H.266/AAC/Opus/G.711

libhls

  1. HLS M3U8: generate m3u8 file
  2. HLS Media: TS segmenter
  3. HLS fmp4 segmenter
  4. HLS Master/Playlist m3u8 parser

libdash

  1. ISO/IEC 23009-1 MPEG-DASH static(vod)
  2. ISO/IEC 23009-1 MPEG-DASH dynamic(live)
  3. DASH MPD v3/v4 parser

libmov

  1. ISO/IEC 14496-12 MP4 File reader/writer
  2. MP4 faststart(moov box before mdat)
  3. fMP4(Fragment MP4) writer
  4. MP4 with H.264/H.265/H.266/AV1/VP8/VP9/JPEG/PNG
  5. MP4 with AAC/Opus/MP3/G.711

libmkv

  1. MKV/WebM file read/write
  2. MKV/WebM live streaming

libsip

  1. sip user-agent (UAC/UAS)
  2. sip with ICE

libhttp(https://github.com/ireader/sdk)

  1. HTTP Server(base AIO)
  2. HTTP Client
  3. HTTP Cookie

Make

  1. make clean && make
  2. make RELEASE=1 (make release library, default debug)
  3. make PLATFORM=arm-hisiv100nptl-linux (cross compile)
编译说明

友情链接

ZLMediaKit 基于C++11的高性能运营级流媒体服务框架
MediaInsight360 流媒体格式在线解析

评论

暂无评论